Vulnerability in Microsoft’s Internet Explorer

Updated: Wednesday, April 30th
Dear Members of the Harvard Community,
The U.S. Department of Homeland Security recommends that all users temporarily discontinue the use of Microsoft Internet Explorer (IE) due to a critical security flaw.
Harvard Information Security recommends that all members of the Harvard community use another browser, such as Mozilla Firefox or Google Chrome, until a fix has been issued for IE.
If Harvard internal sites require the use of IE, please limit use to those specific sites.
For more information about this flaw, please visit the Harvard Information Security website, security.harvard.edu.
Sincerely,
Christian Hamer
University Chief Information Security Officer

___________________________________

Tuesday, April 29th

Many of you may have heard or read in the news of the recent vulnerability in Microsoft’s Internet Explorer. Microsoft has released a work around until a patch is designed to fix this issue. SPH IT is now pushing out this work around to SPH configured Windows 7 PCs. Once this is done the risk is mitigated until the patch is released fixing the vulnerability.

For those not using a Windows PC configured by the SPH IT department or using any Windows XP PC (which is no longer supported by Microsoft and will not be patched at all) we recommend not using Internet Explorer but use a more secure web browser, such as Firefox or Chrome, for all non-Harvard web sites.

Please contact the Helpdesk (helpdesk@hsph.harvard.edu or 617.432.4357) with any questions or concerns.

Thank you,

Bill Mahoney
Director, Information Technology